stdx workspace
This workspace contains 86 crates.
All Crates§
- acme
- 0.1.0 — Async pure-Rust ACME (RFC 8555) client.
- alloc_
counter - 0.1.0 — Per-thread allocation counting for tests.
- anyerr
- 1.0.86 — A trait object based error type for easy idiomatic error handling in Rust applications.
- anyhow
- 0.1.0 — API documentation for the Rust `anyhow` crate.
- axum
- 0.1.0 — This is a pretty straightforward TODO app using the Axum web framework. You can add TODOs to your list but only if they meet certain criteria.
- base32
- 0.1.0 — Fast base32 encoding and decoding with SIMD acceleration, constant-time operations, and `const fn` support.
- base64
- 0.1.0 — Fast base64 encoding and decoding with SIMD acceleration, constant-time operations, and `const fn` support.
- bel
- 0.11.0 — Better Expression Language (BEL), a non-Turing complete expression language designed for simplicity, speed, and safety.
- big_
number - 0.1.0 — Fixed-size unsigned and signed big integers with `u64` limbs.
- constant_
time_ eq - 0.6.1 — Compares two equal-sized byte strings in constant time.
- count_
instructions - 0.2.1 — Counts the instructions executed within a single function.
- countries
- 0.1.0 — ISO 3166-1 alpha-2 country codes and names.
- crc32
- 1.4.2 — Fast, SIMD-accelerated CRC32 (IEEE) checksum computation.
- cron
- 0.12.1 — A cron expression parser and schedule explorer
- crypt
- 0.1.0 — API documentation for the Rust `crypt` crate.
- crypto
- 0.1.0 — Pure Rust cryptography with `no_std` support and hardware / SIMD acceleration for `x86_64`, `aarch64` and WebAssembly.
- crypto_
rustls - 0.1.0 — A `rustls` `CryptoProvider` backed by the stdx `crypto` crate.
- csv
- 0.1.0 — A fast, low-allocation CSV parser with `no_std` and serde support.
- docker
- 0.1.0 — API documentation for the Rust `docker` crate.
- dotenv
- 0.1.0 — Loads environment variables from `.env` files.
- dotenv_
derive - 0.1.0 — API documentation for the Rust `dotenv_derive` crate.
- duplicates
- 0.1.0 — API documentation for the Rust `duplicates` crate.
- embed
- 8.4.0 — Load files into the Rust binary at compile time.
- embed_
impl - 8.4.0 — Implementation of the `Embed` derive macro for the `embed` crate.
- embed_
utils - 8.4.0 — Shared utilities used by the `embed` crate and by `embed_impl`.
- energy_
bench - 0.1.0 — API documentation for the Rust `energy_bench` crate.
- errgroup
- 0.1.0 — API documentation for the Rust `errgroup` crate.
- form_
urlencoded - 1.2.2 — Parser and serializer for the `application/x-www-form-urlencoded` syntax, as used by HTML forms.
- functions
- 0.1.0 — API documentation for the Rust `functions` crate.
- getopts
- 0.2.21 — Simple getopt alternative.
- hex
- 0.1.0 — Fast hex encoding and decoding with SIMD acceleration, constant-time operations, and `const fn` support.
- hostname
- 0.3.1 — API documentation for the Rust `hostname` crate.
- hpke
- 0.1.0 — HPKE: Hybrid Public Key Encryption, as specified in `draft-ietf-hpke-hpke-05` (which obsoletes RFC 9180).
- html_
escape - 0.1.0 — API documentation for the Rust `html_escape` crate.
- hyper_
utils - 0.1.0 — API documentation for the Rust `hyper_utils` crate.
- indexmap
- 2.14.2 — `IndexMap` is a hash table where the iteration order of the key-value pairs is independent of the hash values of the keys.
- ip
- 0.1.0 — API documentation for the Rust `ip` crate.
- ipnetwork
- 0.21.1 — The `ipnetwork` crate provides a set of APIs to work with IPv4 and IPv6 CIDRs in Rust.
- json
- 0.1.0 — API documentation for the Rust `json` crate.
- json_
rpc - 0.1.0 — JSON-RPC 2.0 types and an async server.
- jwt
- 0.1.0 — Sign, parse, and verify JSON Web Tokens (JWT).
- landlock
- 0.1.0 — Sandbox your program with the Linux Landlock LSM.
- mail_
builder - 0.4.0 — `mail_builder` is a flexible e-mail builder written in Rust. It includes the following features:
- maxminddb
- 0.24.0 — A reader for the MaxMind DB file format, including the GeoIP2 and GeoLite2 databases published by MaxMind.
- media_
type - 0.1.0 — Media types (formerly known as MIME types).
- memmem
- 0.1.1 — A crate for substring searching, with functionality similar to the `memmem` function in C.
- net
- 0.1.0 — API documentation for the Rust `net` crate.
- num_
cpus - 1.16.0 — A crate with utilities to determine the number of CPUs available on the current system.
- percent_
encoding - 2.3.2 — URLs use special characters to indicate the parts of the request. For example, a `?` question mark marks the end of a path and the start of a query string. In order for that character to exist inside a path, it needs to be encoded differently.
- pin_
project_ lite - 0.2.14 — A lightweight version of pin-project written with declarative macros.
- postgresql
- 0.1.0 — An async PostgreSQL client with a macro-only, compile-time checked query API.
- postgresql_
derive - 0.1.0 — `#[derive(FromRow)]` for the `postgresql` crate.
- postgresql_
macros - 0.1.0 — Compile-time checked query macros for the `postgresql` crate.
- postgresql_
protocol - 0.1.0 — PostgreSQL wire protocol: message encoding/decoding, type OIDs, and the authentication state machine.
- postmark
- 0.1.0 — API documentation for the Rust `postmark` crate.
- retry
- 0.1.0 — Retry async operations with configurable backoff strategies.
- run_
emitter_ test_ suite - 0.2.11 — API documentation for the Rust `run_emitter_test_suite` crate.
- run_
parser_ test_ suite - 0.2.11 — API documentation for the Rust `run_parser_test_suite` crate.
- ryu
- 1.0.18 — Pure Rust implementation of Ryū, an algorithm to quickly convert floating point numbers to decimal strings.
- s3
- 0.1.0 — A minimal S3 client focused on the most common operations.
- scheduler
- 0.1.0 — API documentation for the Rust `scheduler` crate.
- semver
- 0.1.0 — A Semantic Versioning 2.0.0 parser and comparator.
- serde
- 0.1.0 — API documentation for the Rust `serde` crate.
- serde_
bytes - 0.11.19 — Wrapper types to enable optimized handling of `&[u8]` and `Vec<u8>`.
- serde_
urlencoded - 0.7.1 — `x-www-form-urlencoded` meets Serde.
- serde_
yaml - 0.9.34+deprecated — Rust library for using the Serde serialization framework with data in YAML file format.
- simple
- 0.1.0 — API documentation for the Rust `simple` crate.
- single_
instance - 0.1.0 — A rust library for single instance application.
- singleflight
- 0.1.0 — API documentation for the Rust `singleflight` crate.
- small_
collections - 0.1.0 — Small inline-or-heap collections with a `Vec`/`String`-like API.
- strings
- 0.1.0 — API documentation for the Rust `strings` crate.
- template
- 0.1.0 — A fast, safe template engine for HTML and text rendering, inspired by Jinja2 with `no_std`support.
- term
- 0.1.0 — API documentation for the Rust `term` crate.
- thiserror
- 2.0.21 — A convenient derive macro for the standard library’s `std::error::Error` and `core::error::Error` traits.
- thiserror_
impl - 2.0.21 — API documentation for the Rust `thiserror_impl` crate.
- thiserror_
no_ std_ test - 0.0.0 — API documentation for the Rust `thiserror_no_std_test` crate.
- threads
- 0.1.0 — API documentation for the Rust `threads` crate.
- time
- 0.1.0 — Date and time handling with an embedded IANA time zone database.
- tld
- 0.1.0 — A native Rust library for Mozilla’s Public Suffix List
- tokio_
fast_ udp - 0.1.0 — Fast Unix UDP I/O for tokio.
- unsafe_
libyaml - 0.2.11 — A line-by-line translation of libyaml from C to unsafe Rust.
- uuid
- 0.1.0 — Universally Unique IDentifiers (RFC 9562).
- variables
- 0.1.0 — API documentation for the Rust `variables` crate.
- xxhash
- 0.1.0 — xxHash — extremely fast non-cryptographic hash algorithm.
- zeroize
- 1.9.1 — Securely zero memory (a.k.a. zeroize) while avoiding compiler optimizations.
- zeroize_
derive - 1.5.0 — Custom derive support for `zeroize`